Lock file exists: collection did not finish update cleanly

Description

This error occurs when attempted to start an update on a data source that is in a locked state.

Error message

Displayed in the update-<COLLECTION-ID>.log file

Error: Lock file exists: /opt/funnelback/data/<COLLECTION>/log/<COLLECTION>.lock

Cause

The data source is locked for updating because of one of the conditions:

  • The data source is currently updating.

  • The data source did not finish its previous update cleanly, locking the collection and preventing a subsequent update from occurring.

Resolution

Remove the data source lock files.

From within the search dashboard:

  1. Access the following URL (administration logon required):

    https://<FUNNELBACK-SERVER>/search/admin/run-mediator-command.cgi?mediator_command=ClearLocks&collection=<COLLECTION-ID>
  2. Restart your data source update from the search dashboard.

From the Mediator API:

  1. Access the following URL (administration logon required):

    https://<FUNNELBACK-SERVER>/search/admin/mediator/ClearLocks?collection=<COLLECTION-ID>
  2. Restart your data source update from the search dashboard.