Refusing to bulk load WCAG data

Description

This only applies to the accessibility auditor that shipped prior to Funnelback 15.10.

This error indicates that the WCAG database was not updated due to a crawler error.

Error message

Displayed in the update-<COLLECTION-ID>.log and crawl.log files.

Refusing to bulk load WCAG data since crawler program exited with an error.

Cause

This error indicates that the WCAG database was not updated due to a crawler error. The crawler error that causes this can be investigated by viewing the crawl.log, but is normally a result of failed changeover conditions.

Resolution

If the fail was due to changeover conditions and the smaller index is expected and you want to force the update to complete:

Method 1: manually run the bulk upload

  1. Manually run the bulk load of data:

    $ /opt/funnelback/linbin/java/bin/java -cp "/opt/funnelback/lib/java/all/*" com.funnelback.wcag.journal.WCAGBulkLoader <COLLECTION-ID>
  2. Manually run any post-gather workflow

  3. Start an advanced update of the affected collection from the index phase

  4. The update will fail at the swap views phase (due to failed changeover conditions), then run an advanced update to swap the views.

Method 2: run an update with lower changeover percent

  1. Update the collection.cfg to lower the changeover_percent that is applied to the changeover check. Ensure an appropriate percentage is selected.

  2. Run an update of the collection.