Lock file exists: collection did not finish update cleanly
Description
This error will be displayed if any errors have been logged to the public-ui.warnings
log file.
Error message
Displayed in the update-<COLLECTION-ID>.log
file
Error: Lock file exists: /opt/funnelback/data/<COLLECTION>/log/<COLLECTION>.lock
Cause
The collection is locked for updating because of one of the conditions:
-
The collection is currently updating.
-
The collection did not finish its previous update cleanly, locking the collection and preventing a subsequent update from occurring.
Resolution
Remove the collection’s lock files.
Funnelback 11.0 or newer
From within the administration interface:
-
Switch to the collection
-
Select clear locks from the update tab
-
Restart your collection update
From the Mediator API:
-
Access the following URL (administration interface logon required):
https://<FUNNELBACK-SERVER>/search/admin/mediator/ClearLocks?collection=<COLLECTION-ID>
-
Restart your collection update from the administration interface.
From the command line:
-
Log in to the Funnelback server (server login required) and run the following command:
$ $SEARCH_HOME/bin/mediator.pl ClearLocks collection=<COLLECTION-ID>
-
Restart your collection update from the administration interface.