plugin.[pluginId].version

Specifies the version of the plugin to use.

Key: plugin.[pluginId].version
Type: com.funnelback.plugin.PluginVersion
Can be set in: profile.cfg, collection.cfg
Notes: This option is used by both collections and profiles.

Description

Plugins must be versioned and by default are assumed to be version 1.0.0.

Versions must follow the semver format, in general that looks like:

 major.minor.patch

or if you want extra information

 major.minor.patch-RELEASE

Default Value

By default all plugins are 1.0.0 e.g.

plugin.any-old-plugin.version=1

Examples

Use version 27 of the RFC1149Gatherer plugin.

plugin.RFC1149Gatherer.version=27

© 2015- Squiz Pty Ltd